• Welcome to Jetboaters.net!

    We are delighted you have found your way to the best Jet Boaters Forum on the internet! Please consider Signing Up so that you can enjoy all the features and offers on the forum. We have members with boats from all the major manufacturers including Yamaha, Seadoo, Scarab and Chaparral. We don't email you SPAM, and the site is totally non-commercial. So what's to lose? IT IS FREE!

    Membership allows you to ask questions (no matter how mundane), meet up with other jet boaters, see full images (not just thumbnails), browse the member map and qualifies you for members only discounts offered by vendors who run specials for our members only! (It also gets rid of this banner!)

    free hit counter
  • Gantlin Products, the creator of the WAKE WEDGE is currently running a Group Buy for those of you that want a better, cleaner wake to surf behind your Jetboat! This Group Buy expires on April 1st, so get your order in ASAP to jump on this once a year discount on the Wake Wedge. The discount could go as high as 15% off!

    (You can click the X in the upper right to dismiss this notice)

Port side pump issue

Chip F.

Jet Boat Addict
Messages
182
Ratings
146 5
Points
103
Location
Schuylkill Haven, PA
Boat Make
Yamaha
Year
2016
Boat Model
SX
Boat Length
24
#1
First a little history.. last fall both my pumps were pulled by the dealer in order to repair several gel coat cracks around the mounting bolts of both along with gel coat cracks at my rudder attachments.

Tonight I took the boat out for testing and discovered severe cavitation on the port side as I increased the throttle to it and then the RPMs pegged. If I babied the throttle I was able to get the boat up on plane . I checked the clean out plugs and reseated both but I know that both were seated properly.

I came home and looked at a couple threads on the issue and what I’ve concluded is that the impeller clearance by eyeball looks tight but I did not put a feeler gauge in there. It looks like the tunnel has gaps and that’s what I think the issue is. Looking for experienced opinions. Here are some photos:
186DC5F5-FFCF-4DF4-83A8-445DDC4171A9.jpeg
 
Last edited:

Scottintexas

Jetboaters Captain
Staff member
Messages
3,155
Ratings
2,124 43
Points
243
Location
Corinth, TX (DFW)
Boat Make
Yamaha
Year
2007
Boat Model
AR
Boat Length
23
#2
if you could edit your photo and circle where you think the gaps are, I'm sorry I'm having a hard time seeing them,

What exactly did the dealer remove, nozzles/impeller or intake grates or transom plate?

My cavitation was caused by loose/missing silicone in the intake grate/tunnel area, we also had another member that had to remove his transom plate twice to correct an air intrusion, if I remember correctly,
 

Scottintexas

Jetboaters Captain
Staff member
Messages
3,155
Ratings
2,124 43
Points
243
Location
Corinth, TX (DFW)
Boat Make
Yamaha
Year
2007
Boat Model
AR
Boat Length
23
#4

swatski

Jetboaters Fleet Admiral
Messages
8,789
Ratings
9,441 138
Points
493
Location
Saint Louis, MO
Boat Make
Yamaha
Year
2016
Boat Model
AR
Boat Length
24
#5
Looks like your impeller is fine, it must be the missing sealant - sounds like you are sucking air out of control!

I would pull the pumps and port/blueprint/seal the tunnels.

--
 

Ronnie

Jetboaters Admiral
Messages
4,693
Ratings
3,578 62
Points
308
Location
SF Bay Area
Boat Make
Yamaha
Year
2010
Boat Model
Limited S
Boat Length
24
#6
I think that you should smooth that transition out with 3m 4200 or 5200, a razor blade and some painters tape. Also find someone else to work on your boat. Imho your dealer caused the problem or more of one.
 

Chip F.

Jet Boat Addict
Messages
182
Ratings
146 5
Points
103
Location
Schuylkill Haven, PA
Boat Make
Yamaha
Year
2016
Boat Model
SX
Boat Length
24
#7
I'll pull the pump and check things out and smooth it out. The dealer is almost 3 hrs away. Is the 4200 preferred over the 5200? The boat ran fine prior to the dealer pulling the pumps for the crack repairs. Does anyone know what the black sealant might be that is on there now? Thanks for the input and help.
 

Chip F.

Jet Boat Addict
Messages
182
Ratings
146 5
Points
103
Location
Schuylkill Haven, PA
Boat Make
Yamaha
Year
2016
Boat Model
SX
Boat Length
24
#8
Well I tried to pull it but there is this black gasket material between the pump housing and wear ring and then between the wear ring ang transom plate nothing will budge...
I found the work order for it and it is black 5200.
Should there even be sealent between these?
I thought wasit 4 bolts and pull.


95315CA1-2CF2-4CDF-8B81-C68ACACF7621.jpeg
DA7667B3-492D-4CF7-A14F-C7BFB4C5B293.jpeg
 
Last edited:

Sbrown

Jet Boat Addict
Messages
658
Ratings
693 3
Points
113
Location
Easton, Pa
Boat Make
Yamaha
Year
2017
Boat Model
AR
Boat Length
24
#9
I found the work order for it and it is black 5200.
Should there even be sealent between these?
At least you found out where the missing sealant went.......
 

Cobra Jet Steering LLC

Jetboaters Admiral
Messages
3,270
Ratings
2,994 93
Points
268
Location
Florida
Boat Make
Yamaha
Year
2014
Boat Model
Other
Boat Length
Other
#15
You may want to send all this info to Yamaha including the finger prints on the trailer.
 
Top