1. Welcome to Jetboaters.net!

    We are delighted you have found your way to the best Jet Boaters Forum on the internet! Please consider Signing Up so that you can enjoy all the features and offers on the forum. We have members with boats from all the major manufacturers including Yamaha, Seadoo, Scarab and Chaparral. We don't email you SPAM, and the site is totally non-commercial. So what's to lose? IT IS FREE!

    Membership allows you to ask questions (no matter how mundane), meet up with other jet boaters, see full images (not just thumbnails), browse the member map and qualifies you for members only discounts offered by vendors who run specials for our members only! (It also gets rid of this banner!)

    free hit counter
  2. Reminder of the Lateral Thruster & Thrust Vector group buy through JetBoatPilot.....you only have Until August 31st to get in on this group buy!

    So if you are looking to improve your steering, don't miss this opportunity!  Thank you Will @jetboatpilot for offering this exclusively to JETBOATERS.net members!

    (Logged in Members can click the X in the upper right to dismiss this notice)

    Dismiss Notice

Sea Doo speedster 150 help

Discussion in 'Sea-Doo Jet Boats' started by Rik Mitchell, Jul 26, 2018.

  1. Rik Mitchell

    Rik Mitchell New Member

    Messages:
    1
    Ratings:
    +0 / 0
    Boat Make:
    SeaDoo
    Year:
    2011
    Boat Model:
    Other
    Boat Length:
    Other
    I have a 2011 Sea doo Speedster 150 155 HP. I started the boat on the trailer (not in the water) with a hose. the computer went through its check and I noticed the dash showed SENSOR I have never noticed that before. I was reading posts for sea doo PWC and someone said that if the depth finder is not in the water it will send that SENSOR message. Can anyone confirm that..... The boat started as normal
     
  2. Aces_Over_Kings

    Aces_Over_Kings Well-Known Member

    Messages:
    64
    Ratings:
    +42 / 0
    Boat Make:
    SeaDoo
    Year:
    2010
    Boat Model:
    Other
    Boat Length:
    16
    Hi Rik, late to the party so you may have already received the confirmation you're looking for, but my 2010 behaves similarly. Will give me temperature but "sensor" instead of a depth. Pretty sure this is normal.
     

Share This Page