• Welcome to Jetboaters.net!

    We are delighted you have found your way to the best Jet Boaters Forum on the internet! Please consider Signing Up so that you can enjoy all the features and offers on the forum. We have members with boats from all the major manufacturers including Yamaha, Seadoo, Scarab and Chaparral. We don't email you SPAM, and the site is totally non-commercial. So what's to lose? IT IS FREE!

    Membership allows you to ask questions (no matter how mundane), meet up with other jet boaters, see full images (not just thumbnails), browse the member map and qualifies you for members only discounts offered by vendors who run specials for our members only! (It also gets rid of this banner!)

    free hit counter
  • Gantlin Products, the creator of the WAKE WEDGE is currently running a Group Buy for those of you that want a better, cleaner wake to surf behind your Jetboat! This Group Buy expires on April 1st, so get your order in ASAP to jump on this once a year discount on the Wake Wedge. The discount could go as high as 15% off!

    (You can click the X in the upper right to dismiss this notice)

2000 bass tracker merc sport jet 120 pukes out

Messages
3
Points
1
Boat Make
Other
Year
2000
Boat Model
Other
Boat Length
17
#1
Just got this boat and having a few issues. Initially when it's cold you have to shoot ether into it to get it to fire. I've gone over the entire enricher circuit it's all working. If i plug the air intake for the enricher and crank she fires right over. Had the carb bowls apart very clean inside. That's one issue. The other issue is that when its running if I accelerate slowly it will pick up speed ok but if I romp on the throttle it will puke and studder until I back down. I don't think it's the jet pump,because you can physically hear and feel the engine missing and popping. At full,throttle its a little boggy too. I've checked the carbs and checked the engine compression (around 110 cold in all cylinders) what is the timing procedure? It almost feels like an old car when the vacuum advance doesn't work. I checked the base timing and its at 10 degrees btdc. The cover says 30 so that seems off. I tried adjusting it but ran out of screw. It only seems to move it between 10 and 20 before running out of screw. Is 30 the wot setting or idle? Idk. Can't find a manual anywhere for this things and its a bit more complicated than the old johnsons I'm used to doodling with. Any help would be wonderful. Thanks
 
Messages
3
Points
1
Boat Make
Other
Year
2000
Boat Model
Other
Boat Length
17
#3
Well the timing was correct but I did figure out that the exhaust manifold gasket was blown out letting water into the bottom cylinder. Gaskets on order, I'll let you know how I make out
 
Messages
3
Points
1
Boat Make
Other
Year
2000
Boat Model
Other
Boat Length
17
#4
Just an update. The boat runs perfectly now. The problan was a blown exhaust manifold gasket allowing water to be sucked into the cylinders.
 
Top