• Welcome to Jetboaters.net!

    We are delighted you have found your way to the best Jet Boaters Forum on the internet! Please consider Signing Up so that you can enjoy all the features and offers on the forum. We have members with boats from all the major manufacturers including Yamaha, Seadoo, Scarab and Chaparral. We don't email you SPAM, and the site is totally non-commercial. So what's to lose? IT IS FREE!

    Membership allows you to ask questions (no matter how mundane), meet up with other jet boaters, see full images (not just thumbnails), browse the member map and qualifies you for members only discounts offered by vendors who run specials for our members only! (It also gets rid of this banner!)

    free hit counter

Impeller separating from shaft.

Terrance

Jet Boat Lover
Messages
38
Reaction score
12
Points
67
Location
Porters Lake Nova Scotia Canada
Boat Make
Glastron
Year
2015
Boat Model
GT
Boat Length
19
We have a GT 187 150HP Third time the impeller seems to slip off drive shaft and is separate from engine.
Engine runs fine. Impeller is free wheeling with no propulsion. Boat is at the dealer.
Anyone have this happen? Third time for a repair?
Thanks for any ideas.
Terry
 

Beachbummer

Jetboaters Captain
Messages
2,113
Reaction score
1,425
Points
212
Location
Houston TX
Boat Make
Yamaha
Year
2008
Boat Model
SX
Boat Length
23
I had the opposite happen, The shaft and PTO wear at the PTO side due to lack of grease and/or poor alignment. Any chance the engine has some bad mounts causing it to move? The pump and engine are bolted on such that the shaft size is exact to keep this from happening, so something is funky. The system is not very complex, but with the boat at the dealer they should be able to say what is going on. Their explanation needs to at least make sense and follow logic.

Best of Luck!
 
Top