• Welcome to Jetboaters.net!

    We are delighted you have found your way to the best Jet Boaters Forum on the internet! Please consider Signing Up so that you can enjoy all the features and offers on the forum. We have members with boats from all the major manufacturers including Yamaha, Seadoo, Scarab and Chaparral. We don't email you SPAM, and the site is totally non-commercial. So what's to lose? IT IS FREE!

    Membership allows you to ask questions (no matter how mundane), meet up with other jet boaters, see full images (not just thumbnails), browse the member map and qualifies you for members only discounts offered by vendors who run specials for our members only! (It also gets rid of this banner!)

    free hit counter

Ultranautics Jet Star 1250 nozzle/impeller

butter-bean

Active Member
Messages
53
Reaction score
9
Points
27
Boat Make
Ultranautics
Year
Other
Boat Model
Jetstar
Boat Length
Other
Hello jet star gurus.

my wife took her 1250 out last weekend and said it felt like it lost power. first place i looked was in the nozzle area and i noticed a few things that didnt look right. here is some pics of it
1.one thing i noticed is grooved in the wear ring. is this normal?
2. when i took off the nozzle i noticed the nozzle didnt have a zert fitting every one ive seen does. should i drill and tap to put a fitting there?
3. look at the pic of the shaft side of the area where the shaft sits and there is nothing there ? shouldnt there be a bearing? the parts book calls it a GARLOCK bearing. that is there but almost zero grease. i look at others and i see what looks like a normal bearing not just a copper bushing i call it.. so not sure whats going on.

the impeller looks great no nicks and blades look very good .
 

Attachments

butter-bean

Active Member
Messages
53
Reaction score
9
Points
27
Boat Make
Ultranautics
Year
Other
Boat Model
Jetstar
Boat Length
Other
Hello jet star gurus.

my wife took her 1250 out last weekend and said it felt like it lost power. first place i looked was in the nozzle area and i noticed a few things that didnt look right. here is some pics of it
1.one thing i noticed is grooved in the wear ring. is this normal?
2. when i took off the nozzle i noticed the nozzle didn't have a zert fitting every one ive seen does. should i drill and tap to put a fitting there?
3. look at the pic of the shaft side of the area where the shaft sits and there is nothing there ? shouldn't there be a bearing? the parts book calls it a GARLOCK bearing. that is there but almost zero grease. i look at others and i see what looks like a normal bearing not just a copper bushing i call it.. so not sure whats going on.

the impeller looks great no nicks and blades look very good .
update 5/9/20 drilled and tapped hole for grease fitting on the nozzle cone. all good. but need some help on how to take off the wear ring? once the nozzle is off shouldn't the wear ring slide off? have a new wear ring coming..
 

butter-bean

Active Member
Messages
53
Reaction score
9
Points
27
Boat Make
Ultranautics
Year
Other
Boat Model
Jetstar
Boat Length
Other
update 5/9/20 drilled and tapped hole for grease fitting on the nozzle cone. all good. but need some help on how to take off the wear ring? once the nozzle is off shouldn't the wear ring slide off? have a new wear ring coming..
SOLD THE BOAT NOW HAVE A 96 SEADOO CHALLENGER.
 
Top