• Welcome to Jetboaters.net!

    We are delighted you have found your way to the best Jet Boaters Forum on the internet! Please consider Signing Up so that you can enjoy all the features and offers on the forum. We have members with boats from all the major manufacturers including Yamaha, Seadoo, Scarab and Chaparral. We don't email you SPAM, and the site is totally non-commercial. So what's to lose? IT IS FREE!

    Membership allows you to ask questions (no matter how mundane), meet up with other jet boaters, see full images (not just thumbnails), browse the member map and qualifies you for members only discounts offered by vendors who run specials for our members only! (It also gets rid of this banner!)

    free hit counter
  • Guest, we are pleased to announce that Lectrotab (Linear Devices Corp.) has generously offered discounts on their most popular Trim Tab kits to members of this Forum via a group by that runs through Tuesday, March 31, 2020. ACT FAST...TIME IS RUNNING OUT!!! Lectrotab is offering 55% off on the list price of any Lectrotab Trim tab configuration you can dream up!

    Click Here for more information>Lectrotab group buy for JetBoaters.net members only

    You can dismiss this Notice by clicking the "X" in the upper right>>>>>

Impeller problems

Issue01

Active Member
Messages
5
Reaction score
2
Points
42
Boat Make
Yamaha
Year
2006
Boat Model
SX
Boat Length
23
Hello everyone

I have a question about my impellers.
My boat is a Yamaha SX230 2006
I want to change my impeller. So I want make this today. When i'am finish I see that my old impellers are 6B500 each. I think they are the same at every side.
I know they must be different from stock.

What do you think about that?
Do you think that's bad for performance?

The new ones are from Solas and are also the same at each side. But Solas say this is normal!

Sorry when there are some mistakes in my writing. But English is not my motherlanguage.

Thanks for your answers!

Greedings
Mario
 

Attachments

swatski

Jetboaters Fleet Admiral
Messages
11,284
Reaction score
13,050
Points
672
Location
Saint Louis, MO
Boat Make
Yamaha
Year
2016
Boat Model
AR
Boat Length
24
Hello everyone

I have a question about my impellers.
My boat is a Yamaha SX230 2006
I want to change my impeller. So I want make this today. When i'am finish I see that my old impellers are 6B500 each. I think they are the same at every side.
I know they must be different from stock.

What do you think about that?
Do you think that's bad for performance?

The new ones are from Solas and are also the same at each side. But Solas say this is normal!

Sorry when there are some mistakes in my writing. But English is not my motherlanguage.

Thanks for your answers!

Greedings
Mario
Looks like you have two PORT impeller - the old pair, as indicated by the notches on the impellers' necks.
Did you manage to get those off of the shaft, yet? It can be hard to break those loose sometimes.

With Yamaha boats, if the STRBD and PORT impellers are the same pitch the STRBD may be a bit slower revving, but it is nothing to worry about unless it is really big difference like hundreds of RPM at WOT, the PORT can be pitched a bit more aggressively to even the RPM out.

--
 

Issue01

Active Member
Messages
5
Reaction score
2
Points
42
Boat Make
Yamaha
Year
2006
Boat Model
SX
Boat Length
23
Hy
Thanks for your answer. I just have problems in WOT on the strb engine. It look like cavitation in WOT. The engine sound and rpm goes for some seconds extreme down. When I put the frottles shortly back the rpm came back again. I have this problem many times at WOT this summer. But now I think it's because of the false impeller.
What do you think?
 

swatski

Jetboaters Fleet Admiral
Messages
11,284
Reaction score
13,050
Points
672
Location
Saint Louis, MO
Boat Make
Yamaha
Year
2016
Boat Model
AR
Boat Length
24
Hy
Thanks for your answer. I just have problems in WOT on the strb engine. It look like cavitation in WOT. The engine sound and rpm goes for some seconds extreme down. When I put the frottles shortly back the rpm came back again. I have this problem many times at WOT this summer. But now I think it's because of the false impeller.
What do you think?
Hard to tell, but here are my thoughts. The port vs strbd is not an issue, swapping those (if they were all new and in perfect shape) would not cause the kind of issues you are describing, as far as I know.

Your STRBD(?) (left in the pic) impeller has some dings on the leading edge, that could indeed cause cavitation in the pump, which could cause the impeller to over-rev at WOT and the engine over-revving would hit the (electronic) rev limiter which would then cut out the spark. However, that should not bring the RPM down too too much, unless the engine decides to go into some kind of a limp mode (protective mode), temporarily.

One way to check that would be to file/smooth out the ragged leading edge on that impeller:
1578239810625.png

And see if that helps.
I would also inspect the stator segment to see if anything is broken or missing that could cause excessive cavitation at high revs.
I doubt the new Solas would cure the problem but I could be wrong.

Also - are the main bearings okay? if the impellers rotate on the shaft nice and smooth most likely yes. If you decide to inspect the bearing by pulling the cone off make sure the o-ring is back on when re-assembling.


EDIT:
You could also swap the impellers or the entire impeller/stator/shaft pump assemblies between the sides to try to narrow the potential issues if the strbd side continue to act up after swap this may be an ECU problem etc., unrelated to impellers or pumps.

--
 

Issue01

Active Member
Messages
5
Reaction score
2
Points
42
Boat Make
Yamaha
Year
2006
Boat Model
SX
Boat Length
23
I will change the impeller housing also.
I think the gimbalbearings are OK. But I will double check them of course.
The damage on the strb could be the problem! I will see when I have the new impeller.
Thanks for your answers!
In Austria it tooks a few months until I can check if the old impeller was the problem.
We have snow ❄🌨 here and it's cold outside. It tooks another five months to but my boat into the wather 😭
But the next summer will come😄👍

PS: What do you think about Solars impeller and impeller housing with plastik inlet?
Are they better than stock?
 

swatski

Jetboaters Fleet Admiral
Messages
11,284
Reaction score
13,050
Points
672
Location
Saint Louis, MO
Boat Make
Yamaha
Year
2016
Boat Model
AR
Boat Length
24
I will change the impeller housing also.
I think the gimbalbearings are OK. But I will double check them of course.
The damage on the strb could be the problem! I will see when I have the new impeller.
Thanks for your answers!
In Austria it tooks a few months until I can check if the old impeller was the problem.
We have snow ❄🌨 here and it's cold outside. It tooks another five months to but my boat into the wather 😭
But the next summer will come😄👍

PS: What do you think about Solars impeller and impeller housing with plastik inlet?
Are they better than stock?
As far as I know Solas perform very well in the 230 MR-1 engine pumps, if they are pitched correctly you should be happy.

Looking forward to seeing pictures of your boat on the water! There aren’t many places on this Earth more beautiful than Austrian lakes!

 
Top